Home Forum Getting Started Supported USB drives? Reply To: Supported USB drives?

#418
bb
Participant

If I mount the USB drive on another Linux machine I can see all the files. But, they do not show in the ext4ls on the Macchiatobin board:


Marvell>> usb reset
(Re)start USB...
USB0:   Register 2000120 NbrPorts 2
Starting the controller
USB XHCI 1.00
scanning bus 0 for devices... 2 USB Device(s) found
       scanning usb for storage devices... 1 Storage Device(s) found
       scanning usb for ethernet devices... 0 Ethernet Device(s) found
Marvell>> ext4ls usb 0:1 /
<DIR>       4096 .
<DIR>       4096 ..
<DIR>      16384 lost+found
<DIR>       4096 boot
<DIR>       4096 run
<DIR>       4096 sbin
<DIR>          0 tmp
<DIR>          0 media
<DIR>          0 root
<DIR>          0 home
<DIR>          0 dev
<DIR>          0 etc
<DIR>          0 bin
<DIR>          0 mnt
<DIR>          0 sys
<DIR>       4096 lib
<DIR>          0 opt
<DIR>       4096 proc
<DIR>          0 var
<DIR>          0 srv
<DIR>       4096 usr
Marvell>> ext4ls usb 0:1 /boot
<DIR>       4096 .
<DIR>       4096 ..
Marvell>>

Console output from initial power on:


Marvell>>
BootROM - 2.03
Starting CP-1 IOROM 1.07
Booting from SPI NOR flash 1 (0x32)
Found valid image at boot postion 0x000
lNOTICE:  Starting binary extension
NOTICE:  Gathering DRAM information
mv_ddr: mv_ddr-armada-17.02.0-g42da6da (Mar  9 2017 - 12:02:05)
mv_ddr: completed successfully
Booting Trusted Firmware
BL1: v1.2(release):armada-17.02.0:2017.02-218-g1558a93
BL1: Built : 12:02:06, Mar  9 2017
NOTICE:  BL1: Booting BL2
lNOTICE:  BL2: v1.2(release):armada-17.02.0:2017.02-218-g1558a93
NOTICE:  BL2: Built : 12:02:06, Mar  9 2017
NOTICE:  BL1: Booting BL31
lNOTICE:  BL31: v1.2(release):armada-17.02.0:2017.02-218-g1558a93
NOTICE:  BL31: Built : 12:02:06, Mar  9 2017
l

U-Boot 2015.01-armada-17.02.0 (Mar 09 2017 - 12:01:25)

I2C:   ready
DRAM:  3.8 GiB
Board: MACCHIATOBin-8040
Clock:  CPU     1300 [MHz]
        DDR     800  [MHz]
        FABRIC  800  [MHz]
        MSS     200  [MHz]
        DDR 64 Bit width
        LLC Enabled (Exclusive Mode)
Comphy chip #0:
Comphy-0: PEX0
Comphy-1: PEX0
Comphy-2: PEX0
Comphy-3: PEX0
Comphy-4: KR
Comphy-5: SATA1
Comphy chip #1:
Comphy-0: SGMII1        1.25 Gbps
Comphy-1: SATA0
Comphy-2: USB3_HOST0
Comphy-3: SATA1
Comphy-4: KR
Comphy-5: SGMII2        1.25 Gbps

ERROR: UTMI PHY port type is invalid

at drivers/phy/comphy_cp110.c:1498/comphy_dedicated_phys_init()

ERROR: UTMI PHY port type is invalid

at drivers/phy/comphy_cp110.c:1498/comphy_dedicated_phys_init()

ERROR: UTMI PHY port type is invalid

at drivers/phy/comphy_cp110.c:1498/comphy_dedicated_phys_init()
UTMI PHY 0 initialized to USB Host255
UTMI PHY 1 initialized to USB Host255
UTMI PHY 2 initialized to USB Host255
Now running in RAM - U-Boot at: 3ff0a000
U-Boot DT blob at : 000000003f9f4548
NAND:  0 MiB
MMC:   XENON-SDHCI: 0, XENON-SDHCI: 1
SF: Detected W25Q32BV with page size 256 Bytes, erase size 4 KiB, total 4 MiB
PCIE-0: Link down
SCSI:  SATA link 0 timeout.
SATA link 1 timeout.
AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl SATA mode
flags: 64bit ncq led only pmp fbss pio slum part sxs
SATA link 0 timeout.
SATA link 1 timeout.
AHCI 0001.0000 32 slots 2 ports 6 Gbps 0x3 impl SATA mode
flags: 64bit ncq led only pmp fbss pio slum part sxs
Net:   Skipping disabled port egiga1
Skipping disabled port egiga2
egiga0 [PRIME], egiga1
Warning: egiga1 MAC addresses don't match:
Address in SROM is         00:00:00:00:51:81
Address in environment is  00:00:00:00:51:82
, egiga2, egiga3
Error: egiga3 address not set.

Hit any key to stop autoboot:  0

Technical specification tables can not be displayed on mobile. Please view on desktop