Home Forum Software discussion SBSA support? Reply To: SBSA support?

#470
slimsamu
Participant

Well, I’ve followed the procedure to build the UEFI EDK II – so I have my flash-image.bin now. u

But I’ve not been able to boot it up from a SD card as per http://wiki.macchiatobin.net/tiki-index.php?page=Setup+alternative+boot+sources

fdisk /dev/mmcblk1 reports:

Command (m for help): p
Disk /dev/mmcblk1: 14.9 GiB, 15931539456 bytes, 31116288 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x00000000

Device Boot Start End Sectors Size Id Type
/dev/mmcblk1p1 4096 69631 65536 32M 83 Linux
/dev/mmcblk1p2 69632 31116254 31046623 14.8G 83 Linux

I could successfully mount partition 1 and I placed the flash-image.bin there.

However, when I chance the DIP switch settings to boot from the SD card I see via the serial device:

BootROM – 2.03
Starting CP-0 IOROM 1.07
Booting from SD 0 (0x29)
SD – wait_for_sd_interrupt: Error interrupt – 00008000
SD – wait_for_sd_interrupt: Error interrupt status 00000003
SD – sd_get_cmd_response: Get command response failed.

SD – sd_init: Failed – ret = 00000081
Error: Failed initializing interface
Error: Failed boot attempt 01. error = 0x0C1

BootROM – 2.03
Starting CP-0 IOROM 1.07
Booting from SD 0 (0x29)
Error: no valid header till end of media
pt – 00008000
SD – wait_for_sd_interrupt: Error interrupt status 00000003
SD – sd_get_cmd_response: Get command response failed.

SD – sd_init: Failed – ret = 00000081
Error: Failed initializing interface
Error: Failed boot attempt 02. error = 0x041

BootROM – 2.03
Starting CP-0 IOROM 1.07
Booting from SD 0 (0x29)
Error: no valid header till end of media
pt – 00008000
SD – wait_for_sd_interrupt: Error interrupt status 00000003
SD – sd_get_cmd_response: Get command response failed.

SD – sd_init: Failed – ret = 00000081
Error: Failed initializing interface
Error: Failed boot attempt 03. error = 0x041

BootROM – 2.03
Starting CP-0 IOROM 1.07
Booting from SD 0 (0x29)
Error: no valid header till end of media
pt – 00008000
SD – wait_for_sd_interrupt: Error interrupt status 00000003
SD – sd_get_cmd_response: Get command response failed.

SD – sd_init: Failed – ret = 00000081
Error: Failed initializing interface
Error: Failed boot attempt 04. error = 0x041

Trying Uart..

Not really sure what to do at this stage. I’m reluctant to update the bootloader as described at http://wiki.macchiatobin.net/tiki-index.php?page=Update+the+Bootloader for fear of messing up the board…

Technical specification tables can not be displayed on mobile. Please view on desktop