Home Forum Software discussion Latest branches to be used for building bootloader and kernel?

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #1523
    flotter
    Participant

    Hi,

    I am following the WIKI using Linaro gcc-linaro-7.2.1-2017.11-x86_64_aarch64-linux-gnu.tar.xz cross compiler.

    I am encountering build errors when building the 17.6 release bootloader (also 17.10 fails).

    (1) What is the correct combination of branches to use for the combined bootloader image?

    (2) Should I be able to use the 17.10 release for both the kernel and bootloader for mcbin v1.3?

    Kind Regards,
    Fred

    PS.

    a)
    mv_ddr4_mpr_pda_if.c:708:5: error: suggest explicit braces to avoid ambiguous ‘else’ [-Werror=dangling-else]
    if (subphy_mask != 0xf)

    b)
    lib/psci/psci_common.c: In function ‘psci_do_state_coordination’:
    lib/psci/psci_common.c:220:27: error: array subscript is above array bounds [-Werror=array-bounds]
    psci_req_local_pwr_states[pwrlvl – 1][cpu_idx] = req_pwr_state;

    #1524
    flotter
    Participant

    3) Should I be able to use 17.10 release kernel with 17.6 release bootloader?

    #1525
    nanasi
    Participant

    a) Fixed(pull request) in release armada-17.10.1

    b) The gcc-linaro-5.3.1-2016.05 specified in Official wiki(Toolchain Installation) reports no error.
    Or apply this patch.

    #1528
    blu
    Participant

    Let me just to the above that the native arm64 debian gcc 5.3/5.4 don’t have issues with 17.06.

    #1529
    flotter
    Participant

    Thank you for all the input.

    I am now building kernels natively on the board so all is well.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Technical specification tables can not be displayed on mobile. Please view on desktop