Home Forum Software discussion SBSA support?

Tagged: 

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #445
    slimsamu
    Participant

    Hello,

    Wondering if/when we can expect a new firmware that will make the board SBSA compliant? I’ve managed to get mine up and running following the procedure (kernel build, etc), but to be able to simply install one of the SBSA compliant distros without fuss would be a real bonus.

    Best,

    Gabor

    #456
    HalfBaked
    Participant

    I emailed SolidRun support with this same question and got directed to these wiki pages, which didn’t really answer the question:
    http://wiki.macchiatobin.net/tiki-index.php?page=Software+User+Guide
    http://wiki.macchiatobin.net/tiki-index.php?page=BSP+HowTo

    I’m guessing that if you load up UEFI on your board it should make it SBSA complaint but I can’t find a definitive answer on that.

    #458
    HalfBaked
    Participant

    Is there anyone out there with one of these boards that could run the SBSA Architecture Compliance Suite on it? https://github.com/ARM-software/sbsa-acs

    #470
    slimsamu
    Participant

    Well, I’ve followed the procedure to build the UEFI EDK II – so I have my flash-image.bin now. u

    But I’ve not been able to boot it up from a SD card as per http://wiki.macchiatobin.net/tiki-index.php?page=Setup+alternative+boot+sources

    fdisk /dev/mmcblk1 reports:

    Command (m for help): p
    Disk /dev/mmcblk1: 14.9 GiB, 15931539456 bytes, 31116288 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 512 bytes
    I/O size (minimum/optimal): 512 bytes / 512 bytes
    Disklabel type: dos
    Disk identifier: 0x00000000

    Device Boot Start End Sectors Size Id Type
    /dev/mmcblk1p1 4096 69631 65536 32M 83 Linux
    /dev/mmcblk1p2 69632 31116254 31046623 14.8G 83 Linux

    I could successfully mount partition 1 and I placed the flash-image.bin there.

    However, when I chance the DIP switch settings to boot from the SD card I see via the serial device:

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    SD – wait_for_sd_interrupt: Error interrupt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 01. error = 0x0C1

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 02. error = 0x041

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 03. error = 0x041

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 04. error = 0x041

    Trying Uart..

    Not really sure what to do at this stage. I’m reluctant to update the bootloader as described at http://wiki.macchiatobin.net/tiki-index.php?page=Update+the+Bootloader for fear of messing up the board…

    #180566
    user1
    Participant

    Please help me out…..
    Trying to boot from SD card. Couldn’t find any solution for this.

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    SD – wait_for_sd_interrupt: Error interrupt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 01. error = 0x0C1

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 02. error = 0x041

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 03. error = 0x041

    BootROM – 2.03
    Starting CP-0 IOROM 1.07
    Booting from SD 0 (0x29)
    Error: no valid header till end of media
    pt – 00008000
    SD – wait_for_sd_interrupt: Error interrupt status 00000003
    SD – sd_get_cmd_response: Get command response failed.

    SD – sd_init: Failed – ret = 00000081
    Error: Failed initializing interface
    Error: Failed boot attempt 04. error = 0x041

    Trying Uart..

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.

Technical specification tables can not be displayed on mobile. Please view on desktop